إف تي بي إس
تعريفًا بالموضوع، إن بروتوكول نقل الملفات غير آمن فالمعلوات المنقولة عبر الشبكة أثناء الإتصال بين الزبون والخادم منقولة بوضوح تام ما يمكن أي مستعمل لأبسط أدوات تتبع الشبكات من الحصول على معلومات مثل اسم المستعمل وكلمة المرور والملفات المنقولة لذا يمكن استعمال وسائل أخرى مثل إف تي بي إس. وفيما يلي تفاصيل أوسع عن ذلك.
ومن جهة أخرى، يسمح لمن اتصل بخادم من التحقق من هوية الخادم الذي اتصل به باستخدام شهادة مصادقة كما يسمح بتشفيرالاتصالات كما سبق. فهو يسمح باستخدام أنواع مختلفة منمستويات الأمان:
كذلك، إف تي بي إس هو بروتوكول نقل الملفات الآمن ("FTPs" أو "FTP/SSL") (من الإنجليزية File Transfer Protocol Secure) هو الاسم المستعمل للتعبير عن ميثاق ااتصال بـبروتوكول نقل الملفات عن طريق الـ SSL أو TLS أي عن طريق اتصال مشفر بالإف.تي.بي.
وعلى صعيد آخر، (SSL v2 ، SSL v3 ، TLS v1 ، TLS v1.1)؛ هناك إمكانية للمصادقة باستخدام شهادات ومفاتيح PEM / ASN1 أو PKCS12 عند العمل مع خوادم بروتوكول نقل الملفات الآمن؛ كما يدعم البرنامج عمليات نقل البيانات الآمنة.
بروتوكول نقل الملفات مع تشفير صريح
من جانب آخر، أما أمر "AUTH TLS" (المعروف سابقًا باسم "AUTH TLS-C") يطلب من الخادم تشفير نقل الأمر عبر TLS ، ويتم تشفير نقل البيانات بواسطة الأمر "PROT P"
في هذا الإطار، (غير قياسي) يطلب الأمر «AUTH SSL» (المعروف سابقًا باسم "AUTH TLS-P") من الخادم تشفير نقل الأوامر والبيانات في SSL ويبقى هذا الأسلوب متوافق مع خوادم بروتوكول نقل الملفات أو العملاء الذين لا يدعمون تشفير SSL / TLS ، وفي هذه الحالة يمكن استخدام اتصال غير مشفر أو رفضه.
من جهة ثانية، يتم الاتصال عبرالمنفذ 21 منفذ أوامر بروتوكول نقل الملفات القياسي إلى جانب:
يصف RFC 42171 و RFC 22282 هذه الآلية الصريحة بتشفير TLS.
بروتوكول نقل الملفات مع تشفير ضمني
ومن ناحية أخرى، هذا الأسلوب الأقدم من الطريقة الصريحة غير معتمد من قبل مجموعة مهندسي الإنترنت.
وفي هذا السياق، يتم في هذه الحالة الاتصال بالخادم عبرالمنفذ 990، وهو منفذ الأوامر الذي يتم إجراء تفاوض لاختيار SSL / TLS ويستعمل منفذ 989 كمنفذ مشفر كذلك للبيانات.
وفي هذا السياق، يشبه هذا النهج طريقة عمل HTTPS كما هو موضح في RFC 28183 لأنه يتم التفاوض على SSL / TLS عند الاتصال.
كيفية الإشتغال
وفي هذا السياق، هناك طريقتان لاستدعاء تشفير SSL / TLS مع بروتوكول نقل الملفات، سواء بشكل صريح أو ضمني.
📝 هل في هذه المقالة خطأ؟
إذا وجدت معلومة تحتاج تصحيحاً أو إضافة، أو أردت حذف المقالة، أرسل لنا طلباً وسنراجعه.
ما رأيك في هذه المقالة؟